Forum for users of JoomlaWatch / ExtraWatch for Joomla, Wordpress, Drupal, Magento, Prestashop

JoomlaWatch / ExtraWatch has following features: live real-time visitor statistics, location of your visitors on a map, blocking of users based on bad word list, front-end counters, click heat map, definition of goals and rules, graphs, directory size monitoring, monitoring of increase of database data in time, nightly email reports, interactive HTML5 chart of traffic flow within your website, SEO report with keyword statistics and keyword position trends

Welcome, Guest
Please Login or Register.    Lost Password?

Not all information is showing [solved]
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Not all information is showing [solved]
#423
Not all information is showing [solved] 8 Years, 7 Months ago Karma: 0
I have Joomlawatch installed and running.
But its doesnt show any info for the Latest visitors, bots or the whole center section of information?

Please help!


Thanks in advance.<br><br>Post edited by: matto, at: 2008/02/06 23:15
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#424
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
Have you published the module mod_joomlawatch and do you see an icon of joomlawatch on your website ?
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#425
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
Ok, I think Im gonna feel dumb.

I have published the module and have it posted to &quot;all&quot;pages.

But it isnt in a user position thats visible. So I suppose it needs to be
in a visible module position?




Thanks for the quick reply!
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#426
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
Ok, I now feel dumb.

It seems to work when you have it on a visible module.

Ok, let me ask this then, do you have to have the joomlawatch icon visible on the site, or can I hide it?


Thanks!
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#427
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
No problem..

Yes, it has to be visible for the image to load.
This is the only way how to separate the real visitors and bots (most bots ignore the images)

You can hide the joomlawatch icon by setting the JOOMLAWATCH_BLANK_ICON parameter from '0' to '1' in /components/com_joomlawatch/config.php

Cheers,

Matto
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#428
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
Thank you so very much for your help!
It is greatly appreciated.

I have the icon blank now, thanks to your help!



One last thing and I swear I'll leave you alone.

On the tracking, so far its only showing the index.php as a a tracked page for the latest visitors? I do have it on &quot;all&quot; pages. Can you think of a reason for this?



Thanks again.
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#429
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
In this case, you can try to set the
JOOMLAWATCH_SERVER_URI_KEY in config.php from 'REDIRECT_URL' to 'SCRIPT_URL'
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#431
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
Ive changed it and it still seems to only log the index.php

Any other suggestions?


Thanks.
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#433
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
then temporarily add something like this:

&lt;?php print_r($_SERVER); ?&gt; into your template file /templates/templateYouAreUsing/index.php

and then you'll see a list of other parameters of $_SERVER when browsing your website.

Pick a parameter (shown as capital letters) that's suitable for you (showing what you want to be monitored)

and then use this key instead of REDIRECT_URL in config.php of JoomlaWatch

Matto
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#441
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
Again, thank you so much for help with this.

Ok, I have added the code at the bottom and it is giving me the information.
Im not sure which parameter I should use though.
Heres the link.

www.downtownhuntsville.com


Thanks!
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#442
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
[REQUEST_URI] =&gt; /index.php?option=com_events&amp;Itemid=72

so use REQUEST_URI...
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#445
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
I sincerely appreciate your patience and assistance.

No matter if I get this this working to its fullest ability, so far I am
very impressed with this component and most importantly appreciate your help.

Is there a way to make a donation to support your cause?


So on the question...
I now understand where the [REQUEST_URI] comes from, I looked at every page and saw where the call is just prior to the page it's currently displaying.

But, after adding the REQUEST_URI to the config.php, it still only shows index.php. One note, not sure you would have any idea about this possible conflict, but I am using community builder and the component is called group_jive. I noticed it does display sparse hits to this page as well.

But it still does not display any other pages. Just these two. Mostly just index.php.

Is there anything else you can possibly think of that i can try.
If not, I can still at least use the component for total visitor tracking.


Thanks again!
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#458
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
Hi,
I was out on a weekend, that's why I'm answering just now.
I would suggest you to install and use opensef component for url rewriting.

When using opensef, your URI's are shown the way they are in the flash demo of JoomlaWatch.

I'm using it and this way you'll get a better readability of your website for various bots and of course - visitors, and you can separate the content logically, like here, on my website - /download/ means download, and not index.php?something=something&amp;something...

I placed a paypal donation button on the right side of the website layout, the amount is optional.

If you would like to support the further development of JoomlaWatch, it will be appreciated.

Regards,

Matto<br><br>Post edited by: matto, at: 2008/02/11 22:06
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#460
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
No problem, figured you had some weekend time off!

Thanks so much for the help, I'll give it a shot.

Ive made a donation to your cause. I'm in the US, so I tried as hard as I could to get it close to 20 dollars. Not a lot, but hopefully it helps. I think it'll show up in my wifes name- Laura.


Thanks again!
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#461
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
Great, I recieved it

Thank you!
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#462
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
You're welcome!


Is this the open sef you use?

www.joomlahacks.com/component/option,com...unc,fileinfo/id,317/

For some reason when I enable it, it causes the pages in my site not to load and give me a 404 error... When I disable it, the pages load perfectly...

Any ideas?
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#463
Re:Not all information is showing 8 Years, 7 Months ago Karma: 31
You need to have a proper .htaccess file in your joomla root directory, and of course joomla's url rewriting has to be enabled.

Here's mine:

## Can be commented out if causes errors, see notes above.
Options FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla/MamboDirectory (just / for root)

# RewriteBase /


########## Begin Standard SEF Section
## ALL (RewriteCond) lines in this section are only required if you actually
## have directories named 'content' or 'component' on your server
## If you do not have directories with these names, comment them out.
#
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
#RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
#RewriteRule ^(content/|component/) index.php
#
########## End Standard SEF Section


########## Begin 3rd Party or Core SEF Section
#
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End 3rd Party or Core SEF Section
matto (Admin)
Moderator
Posts: 770
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#464
Re:Not all information is showing 8 Years, 7 Months ago Karma: 0
I tried changing the section of the htaccess as you described and it didnt make any difference. Still get the 404 error on all pages.

I attempted to turn on the core SEO and it causes the same thing to happen.
So i'm thinking maybe I have something wrong with my core...not sure what.

I'll look into it; it seems whatever is causing problems with the opensef is the same issue I have with everything else.

Thanks again for your help and hopefully I can figure out what it is...
funkmanusa (User)
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1

Latest News

Get the latest freelance project announcements
Follow CodeGravity.com

Download ExtraWatch™

ExtraWatch™ FREE is Joomla, Wordpress, Prestashop, Magento plugin with following features: Live Stats, Nightly Email Reports, Goals, Graphs, Anti-spam, History and more